Firefox 4 ha abbandonato la compatibilità con sistemi operativi più vecchi del 10.5 perché utilizza tecnologie presenti da questa versione di OS X in avanti. Esiste però un progetto parallelo chiamato TenFourFox che permette anche agli utenti della 10.4 e inferiori di usare quasi tutte le funzionalità di questa versione.